import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h\\d{1}(?:.*?)>(?<title>.*?)<\\/h\\d{1}>";
final String string = "<h1>This is a large heading</h1>\n"
+ "<p>This is a sample content paragraph.</p>\n"
+ "<h2 style=\"somestyle\">This header line</h2>\n"
+ "<p>This is another content paragraph.</p>\n"
+ "<h2>Another header line</h2>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}