#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?|(date .+)|title .+|whatever.+)"
Local $sString = "+++" & @CRLF & _
"date = 2020-09-08T16:18:51+02:00" & @CRLF & _
"title = "Lire le cycle de l'Assassin Royal, c'est compliqué"" & @CRLF & _
"tags = ["livre"]" & @CRLF & _
"copy = "https://twitter.com/jpcaruana/status/1303356472705921026"" & @CRLF & _
"really_any_key_I_want = "any value"" & @CRLF & _
"+++"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")