// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?|(date .+)|title .+|whatever.+)").unwrap();
let string = "+++
date = 2020-09-08T16:18:51+02:00
title = \"Lire le cycle de l'Assassin Royal, c'est compliqué\"
tags = [\"livre\"]
copy = \"https://twitter.com/jpcaruana/status/1303356472705921026\"
really_any_key_I_want = \"any value\"
+++";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}