import re
regex = re.compile(r"(?|(date .+)|title .+|whatever.+)")
test_str = ("+++\n"
"date = 2020-09-08T16:18:51+02:00\n"
"title = \"Lire le cycle de l'Assassin Royal, c'est compliqué\"\n"
"tags = [\"livre\"]\n"
"copy = \"https://twitter.com/jpcaruana/status/1303356472705921026\"\n"
"really_any_key_I_want = \"any value\"\n"
"+++")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")