using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|(date .+)|title .+|whatever.+)";
string input = @"+++
date = 2020-09-08T16:18:51+02:00
title = ""Lire le cycle de l'Assassin Royal, c'est compliqué""
tags = [""livre""]
copy = ""https://twitter.com/jpcaruana/status/1303356472705921026""
really_any_key_I_want = ""any value""
+++";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}