$re = '/(?|(date .+)|title .+|whatever.+)/';
$str = '+++
date = 2020-09-08T16:18:51+02:00
title = "Lire le cycle de l\'Assassin Royal, c\'est compliqué"
tags = ["livre"]
copy = "https://twitter.com/jpcaruana/status/1303356472705921026"
really_any_key_I_want = "any value"
+++';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);