#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*(Name):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Agent):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Status):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Resource Type):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Resource):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Poll interval):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Batch size):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Condition):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Pattern):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)"
Local $sString = " Name: MONITOR1 Agent: AGENT_QM_1 Status: Started Resource Type: Directory Resource: C:\inputfiles Poll interval: 1 minutes Batch size: 2 Condition: File Size (>= 1B) Pattern: *.txt (wildcard)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")