import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(Name):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\/\\\\]+)\\s*(Agent):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\/\\\\]+)\\s*(Status):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\/\\\\]+)\\s*(Resource Type):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\/\\\\]+)\\s*(Resource):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\/\\\\]+)\\s*(Poll interval):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\/\\\\]+)\\s*(Batch size):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\/\\\\]+)\\s*(Condition):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\/\\\\]+)\\s*(Pattern):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\/\\\\]+)";
final String string = " Name: MONITOR1 Agent: AGENT_QM_1 Status: Started Resource Type: Directory Resource: C:\\inputfiles Poll interval: 1 minutes Batch size: 2 Condition: File Size (>= 1B) Pattern: *.txt (wildcard)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}