$re = '/\s*(Name):\s*([\w\s!@#$&():<>*=\-`.+,\/\\\\]+)\s*(Agent):\s*([\w\s!@#$&():<>*=\-`.+,\/\\\\]+)\s*(Status):\s*([\w\s!@#$&():<>*=\-`.+,\/\\\\]+)\s*(Resource Type):\s*([\w\s!@#$&():<>*=\-`.+,\/\\\\]+)\s*(Resource):\s*([\w\s!@#$&():<>*=\-`.+,\/\\\\]+)\s*(Poll interval):\s*([\w\s!@#$&():<>*=\-`.+,\/\\\\]+)\s*(Batch size):\s*([\w\s!@#$&():<>*=\-`.+,\/\\\\]+)\s*(Condition):\s*([\w\s!@#$&():<>*=\-`.+,\/\\\\]+)\s*(Pattern):\s*([\w\s!@#$&():<>*=\-`.+,\/\\\\]+)/m';
$str = ' Name: MONITOR1 Agent: AGENT_QM_1 Status: Started Resource Type: Directory Resource: C:\\inputfiles Poll interval: 1 minutes Batch size: 2 Condition: File Size (>= 1B) Pattern: *.txt (wildcard)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);