using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^),|DATA\.tracking\.user = \{)\s+([^:]+): (\d+|""[^""]*"")";
string input = @"DATA.tracking.user = {
age: ""19"",
name: ""John doe""
} // This does not works
DATA.tracking.user = { age: ""19"", name: ""John doe"" } // This works
DATA.tracking.user = {
age: ""19"",
name: ""John doe""
} // This does not works";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}