const regex = /(?:\G(?!^),|DATA\.tracking\.user = \{)\s+([^:]+): (\d+|"[^"]*")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^),|DATA\\.tracking\\.user = \\{)\\s+([^:]+): (\\d+|"[^"]*")', 'g')
const str = `DATA.tracking.user = {
age: "19",
name: "John doe"
} // This does not works
DATA.tracking.user = { age: "19", name: "John doe" } // This works
DATA.tracking.user = {
age: "19",
name: "John doe"
} // This does not works`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}