re = /(?:\G(?!^),|DATA\.tracking\.user = \{)\s+([^:]+): (\d+|"[^"]*")/
str = 'DATA.tracking.user = {
age: "19",
name: "John doe"
} // This does not works
DATA.tracking.user = { age: "19", name: "John doe" } // This works
DATA.tracking.user = {
age: "19",
name: "John doe"
} // This does not works'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end