$re = '/(?:\G(?!^),|DATA\.tracking\.user = \{)\s+([^:]+): (\d+|"[^"]*")/';
$str = 'DATA.tracking.user = {
age: "19",
name: "John doe"
} // This does not works
DATA.tracking.user = { age: "19", name: "John doe" } // This works
DATA.tracking.user = {
age: "19",
name: "John doe"
} // This does not works';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);