import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^),|DATA\\.tracking\\.user = \\{)\\s+([^:]+): (\\d+|\"[^\"]*\")";
final String string = "DATA.tracking.user = { \n"
+ " age: \"19\", \n"
+ " name: \"John doe\" \n"
+ "} // This does not works\n\n"
+ "DATA.tracking.user = { age: \"19\", name: \"John doe\" } // This works\n\n"
+ "DATA.tracking.user = { \n"
+ " age: \"19\", \n"
+ " name: \"John doe\" \n"
+ "} // This does not works";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}