#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/[^\/]+\.(?!com|fr|org\b)[a-zA-Z]{2,}"
Local $sString = "va sur https://rcut.in/sa" & @CRLF & _
"https://izi.su/blabla" & @CRLF & _
"https://sn.ms/blabla" & @CRLF & _
"https://abn.ac/lol" & @CRLF & _
"https://fetuj.sk/mdr" & @CRLF & _
"https://cutl.top/1fHnl" & @CRLF & _
"https://www.google.fr" & @CRLF & _
"je suis pas un test" & @CRLF & _
"https://manger.fr" & @CRLF & _
"https://app.mobile.fr" & @CRLF & _
"https://www.hop.fyi/chPsF " & @CRLF & _
"www.google.com" & @CRLF & _
"https://voici.org" & @CRLF & _
"https://www.20minutes.fr/societe/4052202-20230909-choisi-avoir-chien-enfant-temoignage-veterinaire-helene-gateau " & @CRLF & _
"http://url.actualite.fr/89afe2c1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")