using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"https?:\/\/[^\/]+\.(?!com|fr|org\b)[a-zA-Z]{2,}";
        string input = @"va sur https://rcut.in/sa
https://izi.su/blabla
https://sn.ms/blabla
https://abn.ac/lol
https://fetuj.sk/mdr
https://cutl.top/1fHnl
https://www.google.fr
je suis pas un test
https://manger.fr
https://app.mobile.fr
https://www.hop.fyi/chPsF 
www.google.com
https://voici.org
https://www.20minutes.fr/societe/4052202-20230909-choisi-avoir-chien-enfant-temoignage-veterinaire-helene-gateau 
http://url.actualite.fr/89afe2c1
";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}