use strict;
my $str = 'va sur https://rcut.in/sa
https://izi.su/blabla
https://sn.ms/blabla
https://abn.ac/lol
https://fetuj.sk/mdr
https://cutl.top/1fHnl
https://www.google.fr
je suis pas un test
https://manger.fr
https://app.mobile.fr
https://www.hop.fyi/chPsF
www.google.com
https://voici.org
https://www.20minutes.fr/societe/4052202-20230909-choisi-avoir-chien-enfant-temoignage-veterinaire-helene-gateau
http://url.actualite.fr/89afe2c1
';
my $regex = qr/https?:\/\/[^\/]+\.(?!com|fr|org\b)[a-zA-Z]{2,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}