import Foundation
let pattern = #"https?:\/\/[^\/]+\.(?!com|fr|org\b)[a-zA-Z]{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
va sur https://rcut.in/sa
https://izi.su/blabla
https://sn.ms/blabla
https://abn.ac/lol
https://fetuj.sk/mdr
https://cutl.top/1fHnl
https://www.google.fr
je suis pas un test
https://manger.fr
https://app.mobile.fr
https://www.hop.fyi/chPsF
www.google.com
https://voici.org
https://www.20minutes.fr/societe/4052202-20230909-choisi-avoir-chien-enfant-temoignage-veterinaire-helene-gateau
http://url.actualite.fr/89afe2c1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)