# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Version\s*(\S+?),/x/g;t' <<< "2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(24)T8, RELEASE SOFTWARE (fc1)"