re = /Version\s*(\S+?),/
str = '2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(24)T8, RELEASE SOFTWARE (fc1)'
subst = 'x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result