$re = '/Version\s*(\S+?),/';
$str = '2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(24)T8, RELEASE SOFTWARE (fc1)';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;