#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "Version\s*(\S+?),"
Local $sString = "2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(24)T8, RELEASE SOFTWARE (fc1)"
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)