use strict;
my $str = '2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(24)T8, RELEASE SOFTWARE (fc1)';
my $regex = qr/Version\s*(\S+?),/p;
my $subst = 'x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";