package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Version\s*(\S+?),`)
var str = `2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(24)T8, RELEASE SOFTWARE (fc1)`
var substitution = "x"
fmt.Println(re.ReplaceAllString(str, substitution))
}