#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^,]+\K,|,(?=[^,]+$)"
Local $sString = "123,34,56,78,90" & @CRLF & _
"87,65,43,21" & @CRLF & _
"a4,b6,c8888" & @CRLF & _
"11,bbbb,ccccc" & @CRLF & _
"uu,vv,ww,xx" & @CRLF & _
"j,k,l,m,n,o,p"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")