const regex = /^[^,]+\K,|,(?=[^,]+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^,]+\\K,|,(?=[^,]+$)', 'gm')
const str = `123,34,56,78,90
87,65,43,21
a4,b6,c8888
11,bbbb,ccccc
uu,vv,ww,xx
j,k,l,m,n,o,p`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}