using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^,]+\K,|,(?=[^,]+$)";
string input = @"123,34,56,78,90
87,65,43,21
a4,b6,c8888
11,bbbb,ccccc
uu,vv,ww,xx
j,k,l,m,n,o,p";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}