import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^,]+\\K,|,(?=[^,]+$)";
final String string = "123,34,56,78,90\n"
+ "87,65,43,21\n"
+ "a4,b6,c8888\n"
+ "11,bbbb,ccccc\n"
+ "uu,vv,ww,xx\n"
+ "j,k,l,m,n,o,p";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}