import re
regex = re.compile(r"^[^,]+\K,|,(?=[^,]+$)", flags=re.MULTILINE)
test_str = ("123,34,56,78,90\n"
"87,65,43,21\n"
"a4,b6,c8888\n"
"11,bbbb,ccccc\n"
"uu,vv,ww,xx\n"
"j,k,l,m,n,o,p")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")