$re = '/^[^,]+\K,|,(?=[^,]+$)/m';
$str = '123,34,56,78,90
87,65,43,21
a4,b6,c8888
11,bbbb,ccccc
uu,vv,ww,xx
j,k,l,m,n,o,p';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);