#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Z]{1,2}[0-9]{1,2}[A-Z]{0,1}(\s[0-9][A-Z]{0,2})?)"
Local $sString = "Pierre Negre" & @CRLF & _
"Balyasny European Asset Management" & @CRLF & _
"23 King Street, 4th Floor, LONDON, SW1Y 6QY " & @CRLF & _
"City: London, UK SW1Y 6QY W1S 2YZ" & @CRLF & _
"Town: 4th " & @CRLF & _
"02071490070 E14 W1S 4JU"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")