import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{1,2}[0-9]{1,2}[A-Z]{0,1}(\\s[0-9][A-Z]{0,2})?)";
final String string = "Pierre Negre\n"
+ "Balyasny European Asset Management\n"
+ "23 King Street, 4th Floor, LONDON, SW1Y 6QY \n"
+ "City: London, UK SW1Y 6QY W1S 2YZ\n"
+ "Town: 4th \n"
+ "02071490070 E14 W1S 4JU";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}