using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]{1,2}[0-9]{1,2}[A-Z]{0,1}(\s[0-9][A-Z]{0,2})?)";
string input = @"Pierre Negre
Balyasny European Asset Management
23 King Street, 4th Floor, LONDON, SW1Y 6QY
City: London, UK SW1Y 6QY W1S 2YZ
Town: 4th
02071490070 E14 W1S 4JU";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}