import Foundation
let pattern = #"([A-Z]{1,2}[0-9]{1,2}[A-Z]{0,1}(\s[0-9][A-Z]{0,2})?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Pierre Negre
Balyasny European Asset Management
23 King Street, 4th Floor, LONDON, SW1Y 6QY
City: London, UK SW1Y 6QY W1S 2YZ
Town: 4th
02071490070 E14 W1S 4JU
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)