// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z]{1,2}[0-9]{1,2}[A-Z]{0,1}(\s[0-9][A-Z]{0,2})?)").unwrap();
let string = "Pierre Negre
Balyasny European Asset Management
23 King Street, 4th Floor, LONDON, SW1Y 6QY
City: London, UK SW1Y 6QY W1S 2YZ
Town: 4th
02071490070 E14 W1S 4JU";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}