package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z]{1,2}[0-9]{1,2}[A-Z]{0,1}(\s[0-9][A-Z]{0,2})?)`)
var str = `Pierre Negre
Balyasny European Asset Management
23 King Street, 4th Floor, LONDON, SW1Y 6QY
City: London, UK SW1Y 6QY W1S 2YZ
Town: 4th
02071490070 E14 W1S 4JU`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}