package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:Sunscreen|Lubricant)\h+[^()]*\((\d+)\h+Quantity\)`)
var str = `Sunscreen 25g (200 Quantity)
Lubricant 100ml (50 Quantity)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}