import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:Sunscreen|Lubricant)\\h+[^()]*\\((\\d+)\\h+Quantity\\)";
final String string = "Sunscreen 25g (200 Quantity)\n"
+ "Lubricant 100ml (50 Quantity)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}