const regex = new RegExp('\\b(?:Sunscreen|Lubricant)\\h+[^()]*\\((\\d+)\\h+Quantity\\)', 'gm')
const str = `Sunscreen 25g (200 Quantity)
Lubricant 100ml (50 Quantity)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}