import re
regex = re.compile(r"\b(?:Sunscreen|Lubricant)\h+[^()]*\((\d+)\h+Quantity\)", flags=re.MULTILINE)
test_str = ("Sunscreen 25g (200 Quantity)\n"
"Lubricant 100ml (50 Quantity)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")