using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span style=\""font-weight: bold\"">(.*?)<\/span>";
string input = @"<span style=""font-weight: bold"">This is Bold</span><br /><br /><span style=""font-style: italic"">Slant the shit out of this string</span><br /><br />pull this string's pants down</span>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}