import Foundation
let pattern = #"<span style=\"font-weight: bold\">(.*?)<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<span style="font-weight: bold">This is Bold</span><br /><br /><span style="font-style: italic">Slant the shit out of this string</span><br /><br />pull this string's pants down</span>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}