package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<span style=\"font-weight: bold\">(.*?)<\/span>`)
var str = `<span style="font-weight: bold">This is Bold</span><br /><br /><span style="font-style: italic">Slant the shit out of this string</span><br /><br />pull this string's pants down</span>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}