import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span style=\\\"font-weight: bold\\\">(.*?)<\\/span>";
final String string = "<span style=\"font-weight: bold\">This is Bold</span><br /><br /><span style=\"font-style: italic\">Slant the shit out of this string</span><br /><br />pull this string's pants down</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}