use strict;
my $str = '<span style="font-weight: bold">This is Bold</span><br /><br /><span style="font-style: italic">Slant the shit out of this string</span><br /><br />pull this string\'s pants down</span>';
my $regex = qr/<span style=\"font-weight: bold\">(.*?)<\/span>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}