#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<[a-z]+ .*?(href|src|alt)="[^"]+""
Local $sString = "<p>paragraph<a>link</a></p>" & @CRLF & _
"<div class="myclass">" & @CRLF & _
" <div>something</div>" & @CRLF & _
" <div style="mystyle">something</div>" & @CRLF & _
" <b><a href="#">link</a></b>" & @CRLF & _
" <b><a href="#" name="a name">link</a></b>" & @CRLF & _
" <b style="color:red">bold</b> " & @CRLF & _
" <img src="../path" alt="something" />" & @CRLF & _
" <img src="../path" alt="something" class="myclass" />" & @CRLF & _
"</div>'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")