using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[a-z]+ .*?(href|src|alt)=""[^""]+""";
string input = @"<p>paragraph<a>link</a></p>
<div class=""myclass"">
<div>something</div>
<div style=""mystyle"">something</div>
<b><a href=""#"">link</a></b>
<b><a href=""#"" name=""a name"">link</a></b>
<b style=""color:red"">bold</b>
<img src=""../path"" alt=""something"" />
<img src=""../path"" alt=""something"" class=""myclass"" />
</div>'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}