# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<[a-z]+ .*?(href|src|alt)=\"[^\"]+\""
test_str = ("<p>paragraph<a>link</a></p>\n"
"<div class=\"myclass\">\n"
" <div>something</div>\n"
" <div style=\"mystyle\">something</div>\n"
" <b><a href=\"#\">link</a></b>\n"
" <b><a href=\"#\" name=\"a name\">link</a></b>\n"
" <b style=\"color:red\">bold</b> \n"
" <img src=\"../path\" alt=\"something\" />\n"
" <img src=\"../path\" alt=\"something\" class=\"myclass\" />\n"
"</div>'")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.