import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[a-z]+ .*?(href|src|alt)=\"[^\"]+\"";
final String string = "<p>paragraph<a>link</a></p>\n"
+ "<div class=\"myclass\">\n"
+ " <div>something</div>\n"
+ " <div style=\"mystyle\">something</div>\n"
+ " <b><a href=\"#\">link</a></b>\n"
+ " <b><a href=\"#\" name=\"a name\">link</a></b>\n"
+ " <b style=\"color:red\">bold</b> \n"
+ " <img src=\"../path\" alt=\"something\" />\n"
+ " <img src=\"../path\" alt=\"something\" class=\"myclass\" />\n"
+ "</div>'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}