package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[a-z]+ .*?(href|src|alt)="[^"]+"`)
var str = `<p>paragraph<a>link</a></p>
<div class="myclass">
<div>something</div>
<div style="mystyle">something</div>
<b><a href="#">link</a></b>
<b><a href="#" name="a name">link</a></b>
<b style="color:red">bold</b>
<img src="../path" alt="something" />
<img src="../path" alt="something" class="myclass" />
</div>'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}